Android app not working with certain versions of Chrome
Incident Report for Worthy
Resolved
This incident has been resolved.
Posted Aug 09, 2019 - 23:44 UTC
Identified
Google has released a version of Chrome for Android that can cause issues when logging in to our app. Until Google releases a fix for this issue we recommend that customers affected by this bug visit https://worthy.capital in a web browser (the site will work even in Chrome).
Posted Aug 09, 2019 - 20:14 UTC
This incident affected: Worthy Capital App.