Payment Provider Degraded Service
Incident Report for Worthy
Resolved
This incident has been resolved.
Posted Oct 26, 2020 - 13:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 26, 2020 - 13:56 UTC
Investigating
We are currently investigating this issue.
Posted Oct 26, 2020 - 13:32 UTC
This incident affected: Worthy Bond Management API and Worthy Capital App.