Payment provider experiencing intermittent user creation errors
Incident Report for Worthy
Resolved
This incident has been resolved.
Posted May 16, 2019 - 14:47 UTC
Investigating
Our payment provider is investigating this issue.
Posted May 16, 2019 - 14:32 UTC
This incident affected: Worthy Bond Management API.