Instant Account Verification issues
Incident Report for Worthy
Resolved
We have re-enabled Instant Account Verification. We are continuing to monitor users' Funding Sources to ensure the issue has been completely fixed.
Posted Dec 12, 2018 - 17:44 UTC
Identified
We have identified an issue with Instant Account Verification via our third party banking services provider. In some isolated cases, for users with multiple accounts open at the same credit union, the incorrect account would be reported, regardless of the user's selection.

We have disabled IAV until we fix the issue with our banking services provider. Most existing users will not be affected.

New users can choose microdeposit verification to connect a Funding Source.
Posted Dec 11, 2018 - 23:23 UTC
This incident affected: Worthy Capital App.