Service outage
Incident Report for Worthy
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 22:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2021 - 16:32 UTC
Investigating
Our cloud services provider is experiencing intermittent downtime. We are monitoring and will update you on their progress.
Posted Dec 15, 2021 - 15:58 UTC
This incident affected: Worthy Bond Management API and Worthy Capital App.